Zendesk Apps Tools and macOS Catalina

After upgrading my Mac to macOS Catalina, XCode showed me the following fun error upon running the Zendesk Apps Tools.

$ zat new -bash: /usr/local/bin/zat: /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/ruby: bad interpreter: No such file or directory

The following steps fixed the issue: Give Terminal full disk access via the System Preferences:

Run the following in terminal

sudo gem update --system -n /usr/local/bin sudo gem install rake -n /usr/local/bin

Install the xcode command line tools to get Ruby working

xcode-select --install

Reboot! (Trust me. Reboot)

Install the ZAT Tools

sudo gem install zendesk_apps_tools -n /usr/local/bin

Tadaa!